GeoTools : 6 What version of Java do I need to run GeoTools

GeoTools 2.0 to 2.4 requires Java JDK 1.4 or higher.
GeoTools 2.5 requires Java 5 or higher.

GeoTools also needs some standard extensions. For full details on what you will need, see the
Developers Guide on 2.2 Dependencies.